What are the minimum system requirements for Paratext 8?

Was this helpful?

Important Announcement for Paratext 8 Users

Read Announcement

Upgrade to Paratext 9