What's New

File 1061

Missing Verses and How to Get Them Back

There is a problem with Paratext 7 on some machines (3 that I know of) that occasionally causes the following:
When you are editing a paragraph the last verse of the paragraph is erased leaving only the verse number.

We have not been able to determine why this happens on some machines and not others or what triggers the problem. The problem is actually in some Microsoft supplied code, but Clayton has found a way to circumvent this code.

You can do the following:

1) If you see it when it happens, use Control-Z or Edit > Undo to undo the change and restore the verse.

2) If the problem happens and you do not discover it until later:

  • Click in the empty verse
  • Right click and then select View History for Verse(s).
    This will open up a window showing you all the previous versions of this verse. If you have a lot of history this might take some time; you can however cancel at any time and you will see the most recent history that has been found so far.
  • The date and time for each version of the verse is listed in the left hand side. Click on these one at a time starting with the most recent and working back in time until you find the most recent copy of the verse. Once you find the text of the verse, select it and copy edit via Control-C or Right Click and then select Copy. This text will probably have a line through it indicating it has been deleted but that should not effect your ability to copy the verse and paste it into the main window.

This procedure is also useful for verse that have been changed or lost due to other reasons besides Paratext problems.

3) The current test version of Paratext 7.0 has a fix for this problem. If you would be willing to help us test it, do the following:

  • Hold down the Shift key. Click Help > Advanced > Release Stage > Beta
  • Click Help > Check for Updates
  • Restart Paratext after you get the message saying the new version is downloaded.

To stop getting the test release versions in the future

  • Hold down the Shift key, Click Help > Advanced > Release Stage > Normal

Blessings,
Nathan